WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#21873 closed defect (bug) (duplicate)

Visual editor removes valid HTML5 attributes (required, autofocus, placeholder)

Reported by: chirael Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Editor Keywords:
Focuses: Cc:

Description

In HTML editing mode I have a few input fields that I've added the HTML5 required and placeholder attributes to, and one that I added autofocus to.

When I switched the page to Visual editing mode, and then clicked Update, I noticed that my page no longer worked as expected, so then when I clicked back to HTML editing mode, those attributes had been deleted.

Since they are valid HTML5 attributes I don't think WP should be removing them.

(It may remove other HTML5 attributes as well, I haven't checked)

Change History (4)

comment:1 ocean9020 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13314.

comment:2 chirael20 months ago

  • Version changed from 3.4.2 to trunk

Just adding a note that in #13314 comments this is indicated to be Fixed in WP 3.5-alpha

Last edited 20 months ago by chirael (previous) (diff)

comment:3 follow-up: SergeyBiryukov20 months ago

  • Version changed from trunk to 3.4.2

Version number indicates when the bug was initially introduced/reported.

comment:4 in reply to: ↑ 3 chirael20 months ago

Replying to SergeyBiryukov:

Version number indicates when the bug was initially introduced/reported.

Didn't intend to change version num, it was either done automatically by Trac or by a stray key press, sorry about that.

Note: See TracTickets for help on using tickets.