WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#21901 closed feature request (wontfix)

Empty Spam from Dashboard

Reported by: bhoogterp Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.4.2
Component: Administration Keywords:
Focuses: Cc:

Description

A (trash can) icon on the Dashboard to empty SPAM COMMENTS that have been automatically detected by Akismet...

Of course, re-loading back to the "Right Now" box of the DASHBOARD, and not to the [now empty] spam folder would be appropriate, rather than requiring simply another click to get back...

Is just a time-saver when I don't care to look and I don't care to have clutter.

Change History (8)

#1 @bhoogterp
8 years ago

  • Cc benjaminhoogterp@… added
  • Version set to 3.4.2

#2 @knutsp
8 years ago

  • Cc knut@… added

-1 This should be plugin stuff.

A spam plugin could also offer automatic spam deletion. Core should assume that you want to look through your spam before deleting. The core method of catching spam will usually produce false positives.

#3 @MikeHansenMe
8 years ago

I agree that this is plugin territory. Plus, if you click spam from the recent comments box. There is then a button that appears next to filters "Empty Spam".

#4 @MikeHansenMe
8 years ago

  • Cc mdhansen@… added

#5 @bhoogterp
8 years ago

Definately could be a plugin... Just thought it might be a |trivial| modification... The functionality is duplicated via clicking on the "Spam" comments from the Dashboard and then clicking "Empty Spam", and then clicking back to the Dashboard. 3.4.2 with no recent comments but plenty of spam on the dashboard does not have an empty button (or anything). If function of Akismet is suggested that review of all spam is recommemded first, I would reconsider, but I haven't found any legitimate comments picked up by Akismet.

Ultimately, it would be a duplicate of the same link on the Comments page, to empty all spam without reviewing, and it would be different in that it would (hopefully) redirect back to the dashboard rather than an empty spam folder, but the point would simply be to save a few steps towards keeping the spam clutter out of things like the database backups, for instance.

#6 @knutsp
8 years ago

Core only has a simple blacklist of words (actually sub-strings) to determine what is spam or not. As WordPress says in the intro text: Using "press" in the blacklist will mark comments that contain "WordPress" as spam.

Akismet, and other anti-spam plugins, are far more intelligent. You can already instruct Akismet to automatically delete all spam on old posts.

If Akismet introduced a button on the dashboard to empty spam, I would use it frequently. If I didn't have Akismet active, and just some blacklisted words, I would not dare using such a button right from the dashboard. But while viewing the list of spam comments, you have a fair chance to spot a legitimate comment before hitting "Empty spam".

If there is no spam after this button has executed, it could redirect to the previous page, not necessarily the dashboard (not everybody uses the dashboard as a home/central for navigation since the navigation menu is always there). This would require a redirect parameter to be maintained throughout the comments section, just in case you want to finish off with a delete spam action. This, I think, would be too complicated for such a trivial enhancement.

Just curious: Is there a reason to empty spam on a daily basis? If the answer is yes, wouldn't you really need some form of automatic deletion? A plugin that always deletes spam by some trigger would be quite easy to make.

And there are plugins that avoids spam to enter the database in the first place, by either some sophisticated script action or by captcha. Then the number of spam comments in WordPress is always zero.

Suggests wontfix.

#7 @bhoogterp
8 years ago

Fair enough. Failed to recognize difference between core and Akismet. Might be useful for it.

#8 @SergeyBiryukov
8 years ago

  • Component changed from General to Administration
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.