WordPress.org

Make WordPress Core

#21905 closed defect (bug) (duplicate)

Undefined index notices on removal of theme support for custom header or background

Reported by: obenland Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Themes Keywords:
Focuses: Cc:

Description

_remove_theme_support() assumes that the $custom_image_header and $custom_background globals are set, which they are not always. Same goes for the optional 'wp-head-callback' argument for add_theme_support().

Introduced in [20212]. See bug report for Twenty Twelve on Themes Trac.

Attachments (1)

21905.diff (1.4 KB) - added by obenland 19 months ago.

Download all attachments as: .zip

Change History (3)

obenland19 months ago

comment:1 nacin19 months ago

  • Milestone changed from Awaiting Review to 3.5

comment:2 obenland18 months ago

  • Keywords has-patch removed
  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22246.

Note: See TracTickets for help on using tickets.