Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#21928 closed defect (bug) (fixed)

Theme search doesn't always show relevant results

Reported by: SergeyBiryukov Owned by:
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: WordPress.org Site Keywords:
Focuses: Cc:

Description

  1. Go to http://wordpress.org/extend/themes/.
  2. Search for Twenty Ten.
  3. It only appears on the second page of results.

Attachments (1)

21928.twenty-ten.png (240.7 KB) - added by SergeyBiryukov 9 years ago.

Download all attachments as: .zip

Change History (4)

#1 @Otto42
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug.

The theme search is based on the default bbPress search, which is primarily doing a fulltext search against the post text. In this case, it's using the description and how well it matches against the content (aka, a relevancy search). We have code in there to include the slug and title of the theme as well, but that doesn't control the ordering.

You can argue for improving the search as an enhancement, if you like, but it is not a bug, and frankly I don't think it's a discussion appropriate for the core trac at present. Fixing search is a much bigger thing that needs greater discussion all around, not merely half-baked hacks thrown together by the few people who are working on WordPress.org website.

#2 follow-up: @Otto42
9 years ago

  • Resolution changed from invalid to fixed

I've put in a quick patch to bump exact name match searches to the top of the relevant search results. But it will only fix this particular issue. I still think the larger problem of "search" needs to be addressed in general. Quick hacks like this don't solve the underlying problems, IMO.

#3 in reply to: ↑ 2 @SergeyBiryukov
9 years ago

Replying to Otto42:

I've put in a quick patch to bump exact name match searches to the top of the relevant search results. But it will only fix this particular issue.

Thanks, that's what I actually was going to suggest for now, not the general overhaul.

According to the post on make.wordpress.org and subsequent discussion, exact name/slug matches get bumped to the top of results in plugin search as well, so I guess this is more consistent now.

Note: See TracTickets for help on using tickets.