WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#21937 closed enhancement (fixed)

Twenty Twelve: change author IDs to classes

Reported by: thomask Owned by: lancewillett
Milestone: 3.5 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description (last modified by dd32)

Twenty-twelve theme uses content.php this structure:

<div id="author-info">
	<div id="author-avatar">
...
	</div><!-- #author-avatar -->
	<div id="author-description">
...
		<div id="author-link">

almost everywhere WordPress prefers classes from ID's, but here are ID's - problem is, when i want to have more autors per one post (e.g. with co-authors plugin, or using some meta) - i have to rewrite not only the content.php (as this theme do not allow filtering of output, what would be me second enancement request), but i also have to rewrite the css

p.S.: why i can't add new tickets to http://themes.trac.wordpress.org/report?

Attachments (3)

21937.diff (3.3 KB) - added by MikeHansenMe 3 years ago.
content.php update and css updates, let me know if I missed anything.
21937.2.diff (3.7 KB) - added by MikeHansenMe 3 years ago.
updates rtl also.
21937.3.diff (5.2 KB) - added by lancewillett 3 years ago.
Updates author.php as well, same markup

Download all attachments as: .zip

Change History (10)

comment:1 @dd323 years ago

  • Component changed from General to Bundled Theme
  • Description modified (diff)

p.S.: why i can't add new tickets to http://themes.trac.wordpress.org/report?

Thats a trac used specifically for the theme review team before themes are released to extend, it's not a bug reporting playground. This is the correct place to report the bug/enhancement

comment:2 @dd323 years ago

  • Summary changed from change author... ID's to Classes to Twenty Twelve: change author... ID's to Classes

comment:3 @nacin3 years ago

  • Milestone changed from Awaiting Review to 3.5

comment:4 @lancewillett3 years ago

  • Summary changed from Twenty Twelve: change author... ID's to Classes to Twenty Twelve: change author IDs to classes

@MikeHansenMe3 years ago

content.php update and css updates, let me know if I missed anything.

comment:5 @SergeyBiryukov3 years ago

  • Keywords has-patch added

comment:6 @lancewillett3 years ago

content.php update and css updates, let me know if I missed anything.

Probably a few cases in RTL stylesheet as well.

@MikeHansenMe3 years ago

updates rtl also.

@lancewillett3 years ago

Updates author.php as well, same markup

comment:7 @lancewillett3 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In [21941]:

Twenty Twelve: change author template markup to use classes instead of IDs, fixes #21937.

Note: See TracTickets for help on using tickets.