WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 19 months ago

Last modified 17 months ago

#21944 closed enhancement (maybelater)

Allow changing the parameters for built-in post types

Reported by: scribu Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords: has-patch
Focuses: Cc:

Description (last modified by scribu)

Currently, it's really hard to change a single aspect of the built-in post types.

As shown in 3:ticket:21943, users are reverting to all sorts of ugly workarounds.

What's needed is a filter for the args array, before any processing is done inside register_post_type().

Attachments (1)

21944.diff (420 bytes) - added by scribu 19 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 scribu19 months ago

  • Description modified (diff)

scribu19 months ago

comment:2 scribu19 months ago

  • Keywords has-patch added

21944.diff applies the 'post_type_args' filter right after the defaults are set.

comment:4 scribu19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

To summarize, nacin pointed out that with the filter, devs could also mess with capabilities, menus etc. which would break things.

And allowing the filter for non-core post types is very niche, since plugins can just define their own filter, before calling register_post_type().

SergeyBiryukov: Related: #19590

comment:6 MikeSchinkel17 months ago

This is a duplicate of #17447.

Note: See TracTickets for help on using tickets.