WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#21968 closed defect (bug) (duplicate)

Creating a new taxonomy term causes PHP notices

Reported by: ericlewis Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords:
Focuses: Cc:
PR Number:

Description

Creating a new taxonomy term for any taxonomy, eg. from the Tags screen, causes some PHP errors in return, although the term is still created.

Tracked it to changeset:19052, which was a reworking of the WP_Screen object.

Notice: Trying to get property of non-object in /Users/ericlewis/Sites/wp-trunk/wp-admin/includes/class-wp-terms-list-table.php on line 290 Call Stack: 0.0003 691896 1. {main}() /Users/ericlewis/Sites/wp-trunk/wp-admin/admin-ajax.php:0 0.1680 37339784 2. do_action() /Users/ericlewis/Sites/wp-trunk/wp-admin/admin-ajax.php:66 0.1680 37341944 3. call_user_func_array() /Users/ericlewis/Sites/wp-trunk/wp-includes/plugin.php:406 0.1680 37342000 4. wp_ajax_add_tag() /Users/ericlewis/Sites/wp-trunk/wp-includes/plugin.php:406 0.2092 37656960 5. WP_Terms_List_Table->single_row() /Users/ericlewis/Sites/wp-trunk/wp-admin/includes/ajax-actions.php:624 0.2092 37657184 6. WP_List_Table->single_row_columns() /Users/ericlewis/Sites/wp-trunk/wp-admin/includes/class-wp-terms-list-table.php:228 0.2137 37687248 7. call_user_func() /Users/ericlewis/Sites/wp-trunk/wp-admin/includes/class-wp-list-table.php:860 0.2137 37687384 8. WP_Terms_List_Table->column_posts() /Users/ericlewis/Sites/wp-trunk/wp-admin/includes/class-wp-list-table.php:860 0

Attachments (1)

Screen Shot 2012-09-22 at 1.03.23 PM.png (62.9 KB) - added by ericlewis 7 years ago.
screenshot of the PHP notice.

Download all attachments as: .zip

Change History (2)

@ericlewis
7 years ago

screenshot of the PHP notice.

#1 @ocean90
7 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #21871.

Note: See TracTickets for help on using tickets.