WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#21972 closed defect (bug) (duplicate)

Open Sans errors with Twenty Twelve

Reported by: thomask Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Latest Twenty Twelve (i use the version you are pointig to on the latest blog post http://make.wordpress.org/core/2012/09/20/timeline-for-twenty-twelve-1-0-final-testing-window/) uses Open Sans for body time - just few days old version, it was possible to turn it off from customise, today it is there without opt-out.

There are 2 problems

  1. the font uses only west chars - you are loading simple http://fonts.googleapis.com/css?family=Open+Sans and this is by default only west font. You would have to allow cheching what character sets users want, see http://www.google.com/webfonts#QuickUsePlace:quickUse/Family:Open+Sans

or you would have to use version with all of them, but even with those settings there would be (east) countries, which could not use it, so it should be anyway turned off by default and there need to be option to turn it off

  1. the http://fonts.googleapis.com/css?family=Open+Sans url is loaded only when user is logged in. If not, you are trying to load nonexistent http://fonts.googleapis.com/css

Change History (3)

comment:1 @SergeyBiryukov3 years ago

Related: #21751, #21775

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

comment:2 @nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The western character loading is interesting. Can we move that conversation to #21751?

Let's handle the second part in #21973, where I noted I can't reproduce it.

comment:3 @nacin3 years ago

  • Severity changed from blocker to normal

Duplicate of #21973.

Note: See TracTickets for help on using tickets.