WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 3 weeks ago

#22003 closed defect (bug) (wontfix)

Saving custom fields goes to post-new.php rather than post.php

Reported by: curiousdannii Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Posts, Post Types Keywords: needs-patch
Focuses: administration Cc:

Description

Create a new post or page. Add a title and message. Add a custom field (click "Add Custom Field")

The post is saved, but as you are taken to post-new.php rather than post.php, it looks as if your post has disappeared! All is well - it is actually saved - but it's confusing.

Tested on 3.5-alpha-21989

Change History (6)

#1 @ocean90
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #21852 and #21152.

#2 @curiousdannii
6 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I don't believe this is a duplicate of those... it looks to me like the bug is in wp-admin/post.php:

	} elseif ( isset($_POST['addmeta']) && $_POST['addmeta'] ) {
		$location = add_query_arg( 'message', 2, wp_get_referer() );

If I'm reading this code correctly then it just gets the referrer and sends the user back to post-new.php.

#3 @SergeyBiryukov
6 years ago

  • Component changed from General to Administration
  • Milestone set to Awaiting Review
  • Version set to 2.5

Fixing #21152 will restore AJAX in custom fields and eliminate the redirect.

The bug will still be present with JavaScript disabled though. The code was introduced in [7527].

#4 @nacin
5 years ago

  • Component changed from Administration to Posts, Post Types
  • Focuses administration added

#5 @chriscct7
3 years ago

  • Keywords needs-patch added

#6 @iseulde
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

This ticket has not seen any activity in over *two* years, so I'm closing it as "wontfix".

The ticket may lack decisiveness, may have become irrelevant, or may not have gathered enough interest.

If you think this ticket does deserve some attention again, feel free to reopen.

For bugs, it would be great if you could provide updated steps to reproduce against the latest version of WordPress (5.0.2 at the time of writing). Remember images or a video can be superior to explain a problem. At the very least, quickly test again to make sure the bug still exists.

If it’s an enhancement or feature, some extra motivation may help.

Thank you for your contributions to WordPress! <3

Note: See TracTickets for help on using tickets.