WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#22028 closed defect (bug) (duplicate)

Comments feed

Reported by: tlacaelelrl Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Feeds Keywords:
Focuses: Cc:

Description

The problem I have noticed is with the comments feed however I think that this can happen with any of the other feeds.

When there are no comments accessing somedomain.com/comments/feed will cause a 404 error message in some browsers and in others just a blank screen, no errors whatsoever are generated which makes it very hard to figure out what the underlying cause is.

I would suggest providing a message that clearly states the lack of comments instead of a 404 error message or blank page, I think this same problem applies to all other feeds except it is clearly not noticeable as posts are the first things that are created after a clean install but comments can sometimes take longer or may not even happen however the comments feed url is added in the head of the document causing the site to have a broken link.

Change History (2)

#1 @ocean90
8 years ago

Related/Duplicate: #21983, #9611, #13049

#2 @SergeyBiryukov
7 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9611 and #13049.

Note: See TracTickets for help on using tickets.