WordPress.org

Make WordPress Core

#22048 closed defect (bug) (duplicate)

Confirm Navigation dialog on post.php when no changes have been made

Reported by: c3mdigital Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Editor Keywords:
Focuses: Cc:

Description

To reproduce bug:

Go to any post and click update. Click view post or navigate away from post.php

You will get the confirm navigation javascript alert message.

Change History (10)

comment:1 follow-up: TobiasBg22 months ago

I can't reproduce this on trunk.
Tried different scenarios, but only got the message when I had made changes without saving, as expected.

comment:2 in reply to: ↑ 1 ; follow-up: c3mdigital22 months ago

Replying to TobiasBg:

I can't reproduce this on trunk.
Tried different scenarios, but only got the message when I had made changes without saving, as expected.

I've been doing some more testing and this is only happening on posts that have an inserted image in visual mode.

comment:3 in reply to: ↑ 2 SergeyBiryukov22 months ago

  • Milestone changed from Awaiting Review to 3.5

Replying to c3mdigital:

this is only happening on posts that have an inserted image in visual mode.

Confirmed.

comment:4 TobiasBg22 months ago

Ah, yes, for that case I can also confirm it.
Clicking "Update" is not even necessary. Just opening a post/page with an image results in that message when navigating away without doing changes, but only when the "Visual" editor is used.

comment:5 nacin22 months ago

Can someone confirm this is not the case in 3.4? Also, there were two distinct changes here that could have caused this: either r21545 (TinyMCE 3.5.6) or the more recent media changes.

comment:6 SergeyBiryukov22 months ago

Introduced in [22012].

comment:7 markjaquith21 months ago

I did a git bisect, and it says [22120] was the introduction of the bug.

comment:8 markjaquith21 months ago

Need to be on Visual tab.

  • [22012] is where it broke when a single image is embedded.
  • [22120] is where it broke when an image gallery is embedded.

comment:9 SergeyBiryukov21 months ago

Related: #22266 (has an explanation)

Last edited 21 months ago by SergeyBiryukov (previous) (diff)

comment:10 SergeyBiryukov21 months ago

  • Keywords needs-patch removed
  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22266.

Note: See TracTickets for help on using tickets.