WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 8 months ago

#22049 closed enhancement (wontfix)

Reading settings let users choose between "Full text" or "Summary" for the feeds but not for the blog page

Reported by: Lorangeo Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.2
Component: General Keywords:
Focuses: Cc:

Description

Please make the life of new Wordpress users easier.

Why not let users chose with a simple option if they want Wordpress to show the "Full text" or a "Summary" of the posts on the blog page?

Scenario

> OPTION 1:

If user checks option 1 ("Full text") the blog page would always (!) show Full text.

> OPTION 2:

If user checks option 2 ("Summary") the blog page would show summaries based on the following priority order:

1) Teaser (generated with the "more" tag")

2) Manual excerpt (if there is no "more" tag in the post)

3) Automatic excerpt (if there is no manual excerpt and no "more" tag in the post)

The way it is working now seems very confusing to me. Relation between manual excerpts, automatic excerpts and teasers is everything but simple to understand for a beginner. Moreover some themes use the "the_content()" tag in their post template while others use the "the_excerpt()" tag. This makes the whole thing even more difficult to understand when switching from a theme to another.

Such a basic option is available for the feeds. It should also be available for the pages, shouldn't it?

Please check the attached image as my English is not perfect.

Thanks

P.S. The "Post teaser" plugin might be a good starting point.

Attachments (1)

wordpress-reading-settings.jpg (52.7 KB) - added by Lorangeo 19 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 follow-up: c3mdigital19 months ago

  • Severity changed from major to normal
  • Version set to 1.2

This goes against the decisions not options philosophy of WordPress. This is also something that is completely manageable by the theme and can be modified by plugins.

The user already has some level of control and can choose to add the <!--readmore--> tag at any point.

comment:2 alexvorn219 months ago

What do you mean - blog page? the main (front) page?
In this case the settings could be integrated in the theme but not in the core of WordPress, please consider this option for a TwentyTwelve theme...

Everything is already very confusing, why to confuse more and more with manual excerpt and automatic excerpts?
Let's try to make WordPress easier to use and not adding a lot of things that no one real care...

My opinion is to close this.

comment:3 follow-up: Lorangeo19 months ago

If you have a quick look at the reading settings page (Settings > Reading) you'll see that there is an option to show "full text" or "summary" for the posts listed in RSS feeds. And this is soooo simple! It would seem quite logical and obvious to expect the same option in this page for the posts listed in blog pages (@alex: "blog pages" is the term used by WP itself). And I'm saying this especially because I'm sure there are a lot more people who care about their blog page look and feel than people who care about their RSS feeds output.

However there isn't such a simple option for the blog pages. And this really doesn't make sense in a UI perpective.

If you put yourself in the shoes of a Wordpress beginner and look at this page you would not understand why this option is avalaible for the feeds and not for the blog page. This could only leads to frustration and a lot of unnecessary support questions (google it!) for something that should actually be very easy to do.

My suggestion is only to add a simple checkbox that would rely on current existing core features. This would make things a lot more easier for begginers (summary or full text with a single click). At the same time it would still allow theme developers to decide if they want to support teasers ("the_content" tag) or excerpts ("the_excerpt" tag) in their post template. Moreover it would still allow advanced users to insert more tags where they want (if their theme use the "the_content" tag) or set their own manual excerpts (if their theme use the "the_excerpt" tag).

In other words this simple suggestion would not change anything at all. It would only offer a better and easier option for beginners whithout asking them to understand things that even advanced Wordpress users don't understand (relation between teasers, manual excerpts, automatic excerpts and the different ways that themes handle these features (content_tag or excerpt_tag)). It would leave these things "behind the curtain" (can we say that?) for more advanced users while still allowing beginners to easily set up their blog front page.

This seems so obvious to me and such a basic feature that I would consider it an enhancement of major importance, really.

Sorry for my limited English. I hope you understand me.

Last edited 19 months ago by Lorangeo (previous) (diff)

comment:4 in reply to: ↑ 3 DrewAPicture19 months ago

Replying to Lorangeo:

If you have a quick look at the reading settings page (Settings > Reading) you'll see that there is an option to show "full text" or "summary" for the posts listed in RSS feeds. And this is soooo simple! It would seem quite logical and obvious to expect the same option in this page for the posts listed in blog pages

Right, but the issue is that themes (usually) don't control the look and feel of RSS feeds, which is why Core handles it.

It is the job of themes to control how content is outwardly presented to the Web, which is why we have Template Tags to display the_content or the_excerpt. A lot of themes out there both free and commercial bake in options to choose whether full text or excerpts are displayed on any given page.

It really comes down to drawing lines in the sand between what themes, plugins and Core are respectively meant to control. This is theme and/or plugin material.

comment:5 in reply to: ↑ 1 SergeyBiryukov19 months ago

Replying to Lorangeo:

However there isn't such a simple option for the blog pages.

With multiple loops and different ways to present the content, it may be not that simple.

If the_content() would return the excerpt depending on the option and vice versa, it might be even more confusing.

comment:6 alex-ye19 months ago

There is no need to do this it's a theme/plugin option !

comment:8 SergeyBiryukov8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.