WordPress.org

Make WordPress Core

#22062 closed defect (bug) (duplicate)

GET instead of POST in wp_list_table for bulk edit

Reported by: thomask Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Quick/Bulk Edit Keywords:
Focuses: Cc:

Description

I was trying to delete few hundrets of media files at once using bulk edit and i have noticed this error:

Request-URI Too Large
The requested URL's length exceeds the capacity limit for this server.

IMO it would be better to use POST instead of GET for Bulk Edit actions. It works, just the form action have to be replaced, but I am not sure, if it would make some other problems, possibly with others plugins.

Maybe in that case there could be a quick dirty solution - if it is expected, that the bulk edit with fail (e.g. when there is more then some amount of posts listed), switch the action from get to post (But anyway I think, that for bulk action GET should not be used)

Change History (1)

comment:1 scribu19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10762.

Note: See TracTickets for help on using tickets.