WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 18 months ago

Last modified 18 months ago

#22064 closed defect (bug) (maybelater)

Unable to scroll Rich Editor Help on iPad

Reported by: miqrogroove Owned by:
Milestone: Priority: low
Severity: normal Version: 3.4.2
Component: Editor Keywords: dev-feedback
Focuses: Cc:

Description

When clicking the help button in the Editor, there is no way to scroll the help text :( Using a new iPad with iOS 6.

Attachments (1)

Photo_2012_10_01_03h50m20s.png (377.8 KB) - added by miqrogroove 19 months ago.
iPad Screenshot

Download all attachments as: .zip

Change History (19)

comment:1 johnbillion19 months ago

  • Keywords reporter-feedback added

I can't find a help item with enough content to make it scroll. Which one(s) can you see which look like they should scroll?

Also, a two-finger swipe should scroll scrollable things within the page.

comment:2 miqrogroove19 months ago

  • Keywords reporter-feedback removed

I did try two and three finger gestures. I'll put together a screen shot to attach here.

miqrogroove19 months ago

iPad Screenshot

comment:3 johnbillion19 months ago

  • Version changed from 3.4.2 to trunk

comment:4 miqrogroove19 months ago

  • Version changed from trunk to 3.4.2

Please leave the ticket intact.

comment:5 DrewAPicture18 months ago

  • Keywords dev-feedback added
  • Summary changed from Unable to Read Help in Editor on iPad to Unable to scroll Rich Editor Help on iPad

I can confirm the inability to scroll the Rich Editor help text on an iPad (IOS6).

comment:6 georgestephanis18 months ago

Works for me on Android 4.0 Phone (Razr M) -- testing tablet shortly.

EDIT: The phone it works on is running WebKit/535.19 (as per the user-agent)

Last edited 18 months ago by georgestephanis (previous) (diff)

comment:7 georgestephanis18 months ago

  • Keywords reporter-feedback added

My Asus Transformer TF301T running Jelly Bean can scroll it just fine -- also on Webkit/535.19 -- can you confirm what version of webkit it is that's not working properly?

comment:8 DrewAPicture18 months ago

On IOS6 (iPad), I tested

  • Chrome 21 (Webkit 534.46)
  • Safari 6 (Webkit 536.26)

comment:9 follow-up: georgestephanis18 months ago

Drew -- did it work or not?

comment:10 in reply to: ↑ 9 DrewAPicture18 months ago

Replying to georgestephanis:

Drew -- did it work or not?

Nope, just as I said in comment:5 :)

comment:11 DrewAPicture18 months ago

Now that I look at my answers, I realize I had a complete thought over the span of two comments. Sorry for the confusion.

I tested on those two browsers, and no, neither of them can scroll Rich Text help on iPad/IOS6.

comment:12 miqrogroove18 months ago

  • Keywords reporter-feedback removed

No point in asking for feedback on a different platform here. Bug is valid for iPad.

comment:13 follow-up: georgestephanis18 months ago

Sorry, I must be getting tickets confused, I could have sworn I saw a comment remarking that it was happening on Android tablets as well. Sorry about that.

Thanks for following up.

comment:14 in reply to: ↑ 13 DrewAPicture18 months ago

Replying to georgestephanis:

Sorry, I must be getting tickets confused, I could have sworn I saw a comment remarking that it was happening on Android tablets as well. Sorry about that.

You were probably thinking of #22065 or #20614

comment:15 azaozz18 months ago

This is a limitation in Safari on iOS. It doesn't scroll iframwes. Generally the iframe is expanded to its full height and scrolls with the parent, however that fails here too. Will see if we can change the markup so Safari expands the iframe properly.

comment:16 follow-up: nacin18 months ago

  • Keywords punt added
  • Priority changed from normal to low

I think the best way to fix this is to just eliminate the TinyMCE help dialogs and do our own lighter dialogs.

comment:17 in reply to: ↑ 16 azaozz18 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Replying to nacin:

Also in the next version (4.0) of TinyMCE the UI is completely rewritten. Closing as "maybelater" for now, if the problem persists in the new UI we can replace the help modal in 3.6.

comment:18 SergeyBiryukov18 months ago

  • Keywords punt removed
Note: See TracTickets for help on using tickets.