WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#22091 closed defect (bug) (worksforme)

Twenty Ten Theme Div Shift w/ <!--nextpage>

Reported by: lambje Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

When the <!--nextpage--> tag is used the first page of the post has it's DIVs mixed up. Subsequent pages are fine and resemble those of a single page post. Here's the difference in the DIV hierarchy, with Page 2... being what is expected:

Page 1

wrapper

header
main

container

content
primary
secondary

footer

Page 2...n

wrapper

header
main

container

content

primary
secondary

footer

Change History (4)

comment:1 WraithKenny22 months ago

Things like that are usually caused by having an accidental </div> floating around in the post... I can't reproduce the bug in TwentyTen tho... Is it possible the flaw is in your post data? or from a plugin?

comment:2 helenyhou22 months ago

  • Component changed from Themes to Bundled Theme

comment:3 lambje22 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Hmmm, you may be right. I thought the same thing so I turned off all the plugins and tested but I just did a clean WP install, updated the "Hello World" post to add a couple of next page tags and it seems okay. I'll try adding some plugins in one at a time but I guess for now I'll close out this ticket and re-open it if I come across anything. Sorry for the interruption.

Last edited 22 months ago by lambje (previous) (diff)

comment:4 helenyhou22 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.