WordPress.org

Make WordPress Core

#22097 closed enhancement (duplicate)

"comb" css files

Reported by: thomask Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

IMO it would be nice to "comb" CSS files using e.g. (http://csscomb.com/) - it sorts all css properties into logical blocks and in the same order in every declaration, so it is a bit easier to manage it.

Change History (4)

comment:1 ocean9019 months ago

  • Component changed from Bundled Theme to General
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from trivial to normal
  • Status changed from new to closed
Last edited 19 months ago by ocean90 (previous) (diff)

comment:2 thomask19 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I know all this, but it has nothing to do with "combing" the css in the way i describe and in which csscomb.com is doing it e.g. first come properties defining position, then properites defining dimensions, then properties defining style and then final tuning - so in way which designer thinks. In current CSS the properties are sorted somehow randomly or in order which i do not understand, e.g. if you look at (@twenty-twelve)

.widget-area .widget {
	word-wrap: break-word;
	-webkit-hyphens: auto;
	-moz-hyphens: auto;
	hyphens: auto;
	margin-bottom: 48px;
	margin-bottom: 3.428571429rem;
}

... why something like having or not having hyphens got more priority than margin.

Actualy it should be done if you look at current version of CSS coding standards (http://make.wordpress.org/core/handbook/coding-standards/css/#property-ordering) the problem is, that it is not as in example above, so i recoomend to use tools like CSSComb etc.

comment:3 ocean9019 months ago

Yes, but a ticket is not the right place to discuss such things. Therefor we have the UI blog or the IRC chat. If there are many points for such a change a ticket would be fine, IMO.

That's the reason why I have linked to the posts, so that you can add your request there.

Last edited 19 months ago by ocean90 (previous) (diff)

comment:4 helenyhou19 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

We had very, very extensive conversations about this in May, which is where the coding standards come from. However, we specifically discussed that coding standards for the time being would apply to patches and code review moving forward. Without good habits, it would quickly just become a mess again. I would also hesitate to the bundled theme with the discussion of the CSS at large. It would of course be nice to have everything match but you're talking about something that is very new as compared to the long-suffering and constantly changing wp-admin.css.

If there were to be a cleanup, it would happen just once, and as it is, there exists #20570 as a duplicate of this, with discussion as to why we're not doing it now and more.

Note: See TracTickets for help on using tickets.