WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#22098 closed defect (bug) (duplicate)

Some notice errors in media.php

Reported by: alexvorn2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Warnings/Notices Keywords:
Focuses: Cc:

Description

Notice: Undefined index: post_id in D:\Dropbox\htdocs\wordpresslast\wp-admin\includes\media.php on line 1500

Notice: Undefined index: post_id in D:\Dropbox\htdocs\wordpresslast\wp-admin\includes\media.php on line 1780

This happens when you chose to upload a file to the gallery, (ex: in a custom admin panel) , and you don't provide a post id because there is no post, only a custom menu page...

Change History (4)

#1 @SergeyBiryukov
5 years ago

  • Component changed from General to Warnings/Notices

#2 @topdown
5 years ago

  • Version set to 3.4.2

Just seen this error doing some debugging on plugins in WP 3.4.2.

Line 1769 same media.php file. A simple isset() check fixes it.

#3 @nacin
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Fixed in trunk.

#4 @SergeyBiryukov
5 years ago

  • Resolution changed from worksforme to duplicate

Duplicate of #22465.

Note: See TracTickets for help on using tickets.