WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#22126 closed defect (bug) (invalid)

Links in the menu with a hash sign (#) prevent user from deleting menu-items

Reported by: brunoamaral Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Menus Keywords:
Focuses: Cc:

Description

I had a menu to which I tried to add a custom link ending in #

After doing this, I was unable to delete the custom link from the menu.

This problem may also have been caused by having to menu-items with the same name.

This issue was resolved by deleting the whole menu.

Change History (4)

comment:1 SergeyBiryukov19 months ago

  • Keywords reporter-feedback added

Could not reproduce in 3.4 or 3.5-beta1. My steps:

  1. Created a custom link menu item ending in #, saved the menu.
  2. Verified that the link is displayed on the front end.
  3. Deleted the link, saved the menu.
  4. Verified that the link is no longer displayed.
  5. Repeated steps 1 to 4 with a link having the same name as one of the other items. Still was able to delete the link without any issues.

comment:2 brunoamaral19 months ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

Tried to reproduce the bug again without success. closing the issue.

comment:3 brunoamaral19 months ago

  • Keywords needs-testing reporter-feedback removed

comment:4 SergeyBiryukov19 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.