WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#22143 closed enhancement (duplicate)

Generic action for cron events

Reported by: batmoo Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Cron API Keywords: has-patch
Focuses: Cc:
PR Number:

Description

It would be nice to have a generic action in wp-cron.php to allow plugins to hook into cron processing without knowing names of specific registered cron actions, e.g. a plugin that logs all executed cron events.

Attachments (1)

22143.diff (455 bytes) - added by batmoo 7 years ago.

Download all attachments as: .zip

Change History (3)

@batmoo
7 years ago

#1 @batmoo
7 years ago

  • Keywords has-patch added

Patch adds a new action (did_cron), which is executed after the actual cron event and passes in the hook, timestamp, and arguments for the cron event.

#2 @nacin
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18471.

Note: See TracTickets for help on using tickets.