WordPress.org

Make WordPress Core

Opened 7 years ago

Last modified 2 weeks ago

#22146 new enhancement

Uploading Media does not show an error when connection is interrupted

Reported by: pento Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Media Keywords: needs-patch needs-testing close
Focuses: ui, javascript Cc:

Description

When using the multi-file uploader, it doesn't show an appropriate error message when the connection is interrupted briefly. Instead, it jumps to "Crunching..." and gets stuck there, giving the impression that the upload was successful.

To reproduce:

  • Begin an upload - I suggest a file at least a few MB, so you can see the effect more easily. Also, upload to a remote server, so the connection can be easily killed.
  • Upload a few %, then disconnect your computer from the network. I found a 15-20 second disconnect worked most consistently. I was testing with an ethernet connection, I assume WiFi will be the same.
  • Reconnect, and observe the upload bar. If it continues counting up, try disconnecting again, for a little longer.

If you successfully reproduced the bug, it jumps to "Crunching...", without showing an error message.

I've reproduced this behaviour in 3.4.2 as well as trunk.

Change History (10)

#1 @pento
7 years ago

I haven't been able to reproduce the same behaviour using the Customizer uploader - I'm not sure if that's due to differences in the JS, or my own timing problems due to the lack of upload progress feedback.

#2 @nacin
7 years ago

  • Version changed from trunk to 3.3

You said this is reproducible in trunk. Was that on media-new.php, or in the Add Media dialog? The latter uses the same (newer) APIs that the customizer uses.

#3 @pento
7 years ago

Successfully reproduced in trunk with the Add Media dialogue.

#4 @richardmtl
6 years ago

  • Cc richardmtl added

#5 @zoonini
6 years ago

  • Cc zoonini added

#6 @ericlewis
5 years ago

This would be fitting with the autosave feedback a la 3.6.

#7 @ericlewis
5 years ago

  • Focuses ui javascript added
  • Keywords needs-patch added
  • Type changed from defect (bug) to enhancement

#8 @chriscct7
4 years ago

  • Keywords needs-testing good-first-bug added

Good first bug: Is this still reproducible?

#9 @octalmage
3 years ago

I wasn't able to reproduce this in media-new.php or the Add Media dialog. I tried many combinations, and all of them resulted in an HTTP error. See below:

https://cldup.com/etz0JA-GYm.gif

When I disconnected (using Chrome's dev tools), it jumped to 100% and gave an HTTP error.

#10 @adamsilverstein
3 years ago

  • Keywords close added; good-first-bug removed

I tried to test this and was unable to reproduce. Here is a screencast where I switch from 2g to no connection in chrome debugger throttling; not the HTTP error message at the top of the screen when the connection fails.

http://cl.ly/1h0K2N440D3N/Upload_New_Media__WordPress_Dev__WordPress_2016-06-26_14-02-48.jpg

This should probably be closed as invalid.

Note: See TracTickets for help on using tickets.