WordPress.org

Make WordPress Core

#22153 closed defect (bug) (duplicate)

Duplicate Category and Tag Name

Reported by: alogblog Owned by:
Milestone: Priority: normal
Severity: major Version: 3.4.2
Component: Taxonomy Keywords:
Focuses: Cc:

Description

Add a new Tag, for example, "Car". Then it's default slug becomes "car".

And then add a new Category named "Car", which is same to above tag name.

I think its default category slug has to be "car-1", but resulting slug is "car".

I read below documentation in function wp_unique_term_slug($slug, $term);

"The $slug has to be unique global to every taxonomy, meaning that one
taxonomy term can't have a matching slug with another taxonomy term."

Is it bug?

Change History (2)

comment:1 SergeyBiryukov19 months ago

Currently, terms with the same name in different taxonomies can share the same slug.

Related: #5809, #21950, #22023

comment:2 nacin19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5809.

Note: See TracTickets for help on using tickets.