WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 15 months ago

Last modified 15 months ago

#22156 closed enhancement (duplicate)

Modal buttons in TinyMCE don't match WordPress button styles

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.4
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Hit the Help button in the editor. The Close button at the bottom doesn't match our new button styles. It never has matched our buttons, but it looks a little odd now because it's nearly the same but not quite.

Attachments (1)

capture.png (2.1 KB) - added by johnbillion 3 years ago.

Download all attachments as: .zip

Change History (9)

@johnbillion3 years ago

comment:1 @johnbillion3 years ago

  • Summary changed from Close button in editor help doesn't match new button styles to Modal buttons in editor don't match new button styles

Same goes for the buttons in all the editor modals, eg. the colour picker, spellchecker.

comment:2 @nacin3 years ago

  • Component changed from Editor to TinyMCE

comment:3 @SergeyBiryukov3 years ago

  • Type changed from enhancement to defect (bug)

comment:4 @helenyhou3 years ago

  • Summary changed from Modal buttons in editor don't match new button styles to Modal buttons in TinyMCE don't match new button styles

These TinyMCE modals have all kinds of styling problems beyond the submit-type buttons - the close button (ugh), the warning image whose background doesn't match the dialog background, etc. Also, the button is different depending on whether it's a WP-added plugin (like help) or a regular TinyMCE plugin (spellchecker).

comment:5 @ocean903 years ago

  • Summary changed from Modal buttons in TinyMCE don't match new button styles to Modal buttons in TinyMCE don't match WordPress button styles
  • Type changed from defect (bug) to enhancement

They never have been matched our WordPress button styles.

Last edited 3 years ago by ocean90 (previous) (diff)

comment:6 @SergeyBiryukov3 years ago

  • Version changed from trunk to 3.4

comment:7 @iseulde15 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26952.

This has been fixed in 3.9.

comment:8 @ocean9015 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.