WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#22157 closed enhancement (duplicate)

Detecting MIME Types in WXR Files

Reported by: ReadyMadeWeb Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Import Keywords: has-patch
Focuses: Cc:
PR Number:

Description

In the process of creating a service to convert TypePad data to WXR formatted files, we've encountered some unique problems with TypePad data. Namely, many TypePad files are saved without file extensions, which prevents the existing importer from importing those files into the wp-content/uploads folder.

In order to import and rename these otherwise ignored files, we've created a patch for the WordPress importer that does the following:

  1. If there is an attachment in the WXR and the importer is not able to determine the file type from the file name (ie missing extension), the patched version will make a light (body-less) request to the web server where the file is hosted for information we can use about the file. The things we're interested in are file type, size, and filename.
  1. If the importer is processing an attachment under the above situation, and it is able to determine the file type, then it will rewrite the local version of the file to have the appropriate file extension.

This is a simple bit of code, but it makes a huge difference as TypePad saves without file extensions quite regularly.

We've attached our patch and a sample WXR file from ragsgupta.com, the Brightcove co-founder's blog.

Attachments (2)

readymadeweb-filetype-HEAD.patch (4.1 KB) - added by ReadyMadeWeb 7 years ago.
Patch to WordPress Importer
www.ragsgupta.com-16.zip (519.6 KB) - added by ReadyMadeWeb 7 years ago.
Example WXR Import File

Download all attachments as: .zip

Change History (3)

@ReadyMadeWeb
7 years ago

Patch to WordPress Importer

@ReadyMadeWeb
7 years ago

Example WXR Import File

#1 @nacin
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21913.

Note: See TracTickets for help on using tickets.