WordPress.org

Make WordPress Core

#22163 closed defect (bug) (duplicate)

SimplePie removes methods in 1.3

Reported by: nacin Owned by:
Milestone: Priority: normal
Severity: blocker Version:
Component: External Libraries Keywords: has-patch
Focuses: Cc:

Description (last modified by nacin)

From the changelog:

  • The ability to pass parameters into the SimplePie constructor has been removed. Use the SimplePie::set_feed_url() method instead.
  • The SimplePie::get_favicon() and SimplePie::set_favicon_handler() methods have been removed.
  • SimplePie::subscribe_*() methods have also been removed (with the exception of SimplePie::subscribe_url()).
  • SimplePie::enable_xml_dump() has been removed and replaced with SimplePie::get_raw_data().

Change History (8)

comment:1 nacin18 months ago

  • Description modified (diff)

comment:2 rmccue18 months ago

Upstream #243 fixes the cache class problem.

comment:3 rmccue18 months ago

Favicons fixed upstream in master and one-dot-three.

(That can be made protocol-relative if you think that'd work better.)

Last edited 18 months ago by rmccue (previous) (diff)

comment:4 rmccue18 months ago

Fixed constructor stuff in master and one-dot-three.

comment:5 rmccue18 months ago

  • Keywords has-patch added

Fixed subscribe_* and enable_xml_dump in master and one-dot-three.

comment:6 rmccue18 months ago

  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22321.

comment:7 nacin11 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:8 nacin11 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #22321.

Just testing duplicates.

Note: See TracTickets for help on using tickets.