WordPress.org

Make WordPress Core

#22179 closed defect (bug) (fixed)

Twenty Twelve: style MultiSite messages and forms

Reported by: pavelevap Owned by: lancewillett
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.5
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

I tested Twenty Twelve with Multisite and it does not look very good (see attached screenshot). Maybe bundled themes could also support basic Multisite forms and activation messages?

Attachments (7)

Twenty_Twelve_Multisite.jpg (53.0 KB) - added by pavelevap 21 months ago.
22179-standalone.diff (764 bytes) - added by DrewAPicture 21 months ago.
Standalone ul, li, p, h2
22179-standalone.png (94.4 KB) - added by DrewAPicture 21 months ago.
22179-standalone-2.png (50.5 KB) - added by DrewAPicture 21 months ago.
22179-standalone-3.png (54.5 KB) - added by DrewAPicture 21 months ago.
22179-2.diff (908 bytes) - added by DrewAPicture 21 months ago.
targeted
22179.3.diff (1.5 KB) - added by obenland 20 months ago.

Download all attachments as: .zip

Change History (20)

comment:1 obenland21 months ago

  • Summary changed from Bundled themes should support for Multisite? to Bundled themes should support for Multisite? (Twenty Twelve)

comment:2 DrewAPicture21 months ago

  • Cc xoodrew@… added
  • Keywords needs-patch added

Confirmed the problem on Multisite. Definitely doesn't look good at all. Nice catch @pavelevap!

comment:3 follow-up: DrewAPicture21 months ago

Looks to me like the biggest problem here is that all standard styles are currently targeted, meaning we don't have standalone p, ul, li, h2 in the stylesheet. I propose we add the untargeted styles but I'm working two patches, so @lancewillet or whomever can choose.

DrewAPicture21 months ago

Standalone ul, li, p, h2

comment:4 DrewAPicture21 months ago

  • Keywords 2nd-opinion added

22179-standalone.diff adds standalone ul, li, p and h2 styles. I've also attached three resulting screenshots:

I'm scrapping my effort on the override/targeted patch, mostly because we'd essentially be printing the original styles followed by the overriding styles in the page (which is lame).

On a side note, wp-signup.php looks like a primo candidate for some love at WCDenver Hack Day this weekend.

I'm reasonably confident the standalone styles will suffice here, but I'd love to hear others' feedback.

comment:5 DrewAPicture21 months ago

  • Keywords has-patch added; needs-patch removed
  • Summary changed from Bundled themes should support for Multisite? (Twenty Twelve) to Twenty Twelve: style MultiSite messages and forms

comment:6 in reply to: ↑ 3 ; follow-up: lancewillett21 months ago

  • Priority changed from normal to low

Replying to DrewAPicture:

Looks to me like the biggest problem here is that all standard styles are currently targeted, meaning we don't have standalone p, ul, li, h2 in the stylesheet. I propose we add the untargeted styles but I'm working two patches, so @lancewillet or whomever can choose.

I don't think we should add any standalone styles. Much better to target with a specific class, please.

Shouldn't system messages like this be styled by WP core itself?

comment:7 in reply to: ↑ 6 DrewAPicture21 months ago

Replying to lancewillett:

Shouldn't system messages like this be styled by WP core itself?

The form elements are styled in-file, but it's assumed that themes will supply basic untargeted ui, li, p and h2 styles, as every theme I've tested besides Twenty Twelve seem to have.

Last edited 21 months ago by DrewAPicture (previous) (diff)

DrewAPicture21 months ago

targeted

comment:8 follow-up: DrewAPicture21 months ago

22179-2.diff adds the styles targeted to the .mu_register class.

I still don't really understand the hesitation behind providing basic un-targeted element type selector styles for p, h-tags, lists, etc. They could be easily bundled in with existing rules.

comment:9 in reply to: ↑ 8 lancewillett21 months ago

Replying to DrewAPicture:

22179-2.diff adds the styles targeted to the .mu_register class.

I still don't really understand the hesitation behind providing basic un-targeted element type selector styles for p, h-tags, lists, etc. They could be easily bundled in with existing rules.

Because we've already launched the theme publicly, and we need to be *very* careful about changing styles that could break things. We can do it, just will take oodles of testing so won't be a quick one to commit.

comment:10 lancewillett21 months ago

  • Milestone changed from Awaiting Review to 3.5

comment:11 lancewillett20 months ago

  • Priority changed from low to normal

comment:12 lancewillett20 months ago

  • Keywords 2nd-opinion removed

I think our best approach here is to add selectors for .mu_register in with the existing .entry-content selectors; then anything that's specific to multisite can go below in its own rule block.

obenland20 months ago

comment:13 lancewillett20 months ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 22579:

Twenty Twelve: style Multisite messages and forms to match the theme styles. Props DrewAPicture and obenland, fixes #22179.

Note: See TracTickets for help on using tickets.