WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#2218 closed defect (bug) (worksforme)

Pop-up window for inserting hyperlinks truncated on FireFox 1.5

Reported by: howtoblog Owned by:
Milestone: Priority: low
Severity: normal Version: 2.0
Component: Administration Keywords:
Focuses: Cc:

Description

In testing the new wysiwyg interface on my first WordPress 2.0 blog, I experienced problems with inserting hyperlinks when using FireFox 1.5 as my browser (these problems disappeared when I switched to Internet Explorer).

Specifically, the dialog box that pops up when you click on the insert hyperlink button is truncated such that approximately the last 25% of the content that displays in that window is cut off. Furthermore, the window is not resizeable, nor does it have scrollbars. As a result, the user is unable to see the full URL that they are entering for the hyperlink (and can reach a point where they are essentially typing blindly because once your text enters the truncated portion, you can't see anything that you're typing). This same problem is encountered when one tries to enter a title for the hyperlink.

Given that hyperlinking is a significant component of blogging, and that a percentage of the WP community uses Firefox as their browser of choice, being forced to use IE in order to have full functionality of WP 2.0 admin interface is dismaying.

Attachments (1)

wordpress-hyperlink-problem.jpg (50.9 KB) - added by howtoblog 9 years ago.
Screenshot of truncated dialog box

Download all attachments as: .zip

Change History (6)

@howtoblog9 years ago

Screenshot of truncated dialog box

comment:1 @davidhouse9 years ago

I can't replicate this in Fx/1.5/Linux. Care to share some more on your environment, as well as trying disabling all your Firefox extensions?

comment:2 @howtoblog9 years ago

  • Priority changed from high to low

I'm using WinXP Media Center Edition with service pack 2 installed. I'm sorry I did not check back on the status of this ticket until now.

Prior to checking back on this ticket status, I recently added several new Firefox extensions and all of a sudden the dialog box from WP is no longer truncated.(See below for my list of extensions - I noticed the change after installing SpellBound, Mozilla SpellCheck Libraries, and Performancing)

So the problem is definately related somehow to the use of Firefox extensions. The ones I have installed are:

DOM Inspector 1.8

Talkback 1.5

Auto Copy 0.6.0

FlashGot 0.5.9.99

Adsense Notifier 0.7

ConQuery 1.6.2

LinkChecker 0.4.3

Copy Links 0.1.3

Context Highlight 0.2

TargetKiller 0.3

Sage 1.3.6

Google Pagerank Status 0.9.3

DownThemAll! 0.9.8.4

Copy URL+ 1.3.2

Disable Targets For Downloads 1.0

IE View 1.2.7

BetterSearch 1.9

SpellBound 0.7.3

Mozilla SpellCheck Libraries 1.0.1.0

Performancing 1.0.1

Google Toolbar for Firefox 1.0.20051122

I don't know if the fact that it is due to a Firefox extension makes it not a WP issue or not, but at least now you're aware of it (and I honestly don't know why adding new extensions fixed the problem, but I'm glad they did as I hate using IE)

comment:3 @marcusv9 years ago

I have the same problem. However my hyperlink box was much more severly truncated!

I am using Firefox 1.5.0.1 on Windows 2000 SP4, though it does the same on Windows XP.

I took the advice here and started disabling plugins for Firefox and after re-enabling one by one, I've discovered multiple culprits! It seems that the more of these plugins you have installed, the more truncated the window becomes. Here are the plugins I've discovered that shrink the Wordpress hyperlink popup window:

Fasterfox 1.0.3

Adblock 0.5.3.042

SwitchProxy Tool 1.3.4

SiteAdvisor Firefox Extension 20.0

comment:4 @mdawaffe9 years ago

howtoblog, marcusv,

Can either oy you replicate this bug in the most recent version of WP/FF?

comment:5 @rob1n8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

A few pointers:

  1. Firefox 2.0.0.3 (or whatever) is out now, so either upgrade, or:
  1. We use different boxes now, so I think this problem's probably gone.

I couldn't reproduce with FF 2.0.0.3 on OS X 10.4.

Note: See TracTickets for help on using tickets.