WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 5 years ago

#22214 closed defect (bug) (duplicate)

Inconsistency in the show_ui parameter for register_post_type

Reported by: nofearinc Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Posts, Post Types Keywords:
Focuses: administration Cc:

Description

There is an inconsistency with the show_ui argument to register_post_type. When set to false, the post type listing page is open, while the 'Add new' page is not accessible.

Change History (5)

#1 follow-up: @DrewAPicture
8 years ago

  • Keywords dev-feedback added

Seems to be a duplicate of #13403 though that ticket was marked as fixed.

#2 @nacin
7 years ago

  • Component changed from Administration to Posts, Post Types
  • Focuses administration added

#3 @SergeyBiryukov
6 years ago

#31397 was marked as a duplicate.

#4 in reply to: ↑ 1 @SergeyBiryukov
6 years ago

  • Version changed from 3.4.2 to 3.3

Replying to DrewAPicture:

Seems to be a duplicate of #13403 though that ticket was marked as fixed.

The inconsistency was introduced in [19321], where a part of [14674] was reverted in edit.php, but not in post-new.php.

#5 @ocean90
5 years ago

  • Keywords dev-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

#33763 has a patch.

Note: See TracTickets for help on using tickets.