WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#2226 closed defect (bug) (duplicate)

<!--more--> tag is not handled correctly when posting via XML-RPC

Reported by: bytescout Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Administration Keywords: XML-RPC moretag Metaweblog NewPost
Focuses: Cc:

Description

<!--more--> tag is removed automatically from post content when posting via XML-RPC interface. This is caused by function wp_insert_post from functions-post.php called from implementation for MetaWeblog.NewPost

To solve this problem just comment the following line in function wp_insert_post in functions-post.php:

$post_content = apply_filters('content_save_pre', $post_content);

so <!--more--> tag won't be removed anymore then you add new post via XML-RPC.

Change History (3)

comment:1 bytescout8 years ago

  • Milestone set to 2.0.1
  • Version changed from 1.2 to 2.0

comment:2 ryan8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2130

comment:3 anonymous7 years ago

  • Milestone 2.0.1 deleted

Milestone 2.0.1 deleted

Note: See TracTickets for help on using tickets.