Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#22291 closed enhancement (duplicate)

Need Hook for wp_unique_post_slug and wp unique term slug

Reported by: baernty Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Permalinks Keywords:
Focuses: Cc:


I use the "WP No Category Base" Plugin (http://wordpress.org/extend/plugins/wp-no-category-base/) to get prettier URLs. If I use the same slug for a category and a page i get into conflict. The URL of the page is not available anymore. It would be nice to have a check if there is a page with the same slug if I want to save a category slug.

Therefore a change of the code or a hook (to do it by myself) would be awesome!

Thanks very much!!

Change History (1)

#1 @SergeyBiryukov
3 years ago

  • Component changed from General to Permalinks
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

wp_unique_post_slug() already has a set of fiters, see #14111, #15726, and #20480.

wp_unique_term_slug() part is a duplicate of #20783.

Note: See TracTickets for help on using tickets.