WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#22298 closed defect (bug) (fixed)

Permalink box line-wrap covers the media button

Reported by: tar.gz Owned by: azaozz
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.5
Component: UI Keywords: has-patch
Focuses: Cc:

Description

When a certain combination of narrow screen size and long permalink string occurs, the permalink box underneath the title box wraps on a second line.

In pre-3.5 WordPress this didn't cause overlap, because there was sufficient whitespace to allow the second line.

In the current beta of WordPress 3.5 [22252], when a line wrap occurs, the "Edit", "View Post" and "Get Permalink" buttons get hidden by the new media upload button (introduced with #19956).

Related: #22184

Attachments (4)

upload-url-line-wrap.png (34.9 KB) - added by tar.gz 18 months ago.
Overlap of buttons caused be the permalink line wrap
22298.png (14.7 KB) - added by SergeyBiryukov 18 months ago.
22298.patch (491 bytes) - added by SergeyBiryukov 18 months ago.
22298.after.png (15.4 KB) - added by SergeyBiryukov 18 months ago.

Download all attachments as: .zip

Change History (13)

tar.gz18 months ago

Overlap of buttons caused be the permalink line wrap

comment:1 SergeyBiryukov18 months ago

  • Milestone changed from Awaiting Review to 3.5

comment:2 SergeyBiryukov18 months ago

Caused by #edit-slug-box { height: 1em; }, reintroduced in [22279].

Last edited 18 months ago by SergeyBiryukov (previous) (diff)

SergeyBiryukov18 months ago

SergeyBiryukov18 months ago

SergeyBiryukov18 months ago

comment:3 SergeyBiryukov18 months ago

  • Keywords has-patch added

Tested in Firefox 16, Chrome 22, IE 8, Opera 12.

comment:4 georgestephanis18 months ago

Testing patch to see if it reintroduces the jump from #22184

comment:5 follow-up: georgestephanis18 months ago

Works beautifully for me, my only thought is the units for the min-height -- it was em before the patch, now is px

comment:6 azaozz18 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 22328:

Fix the permalink covering the insert media button when wrapped, props SergeyBiryukov, fixes #22298

comment:7 in reply to: ↑ 5 azaozz18 months ago

Replying to georgestephanis:

Don't think height/min-height is needed there at all.

comment:8 azaozz18 months ago

In 22329:

Min-height on the permalink wrapper prevents the editor jumping down when starting new post, props SergeyBiryukov, see #22298

comment:9 tar.gz18 months ago

Working perfectly - thanks Sergey for this quick fix!

Note: See TracTickets for help on using tickets.