WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#22349 closed enhancement (wontfix)

options-privacy.php should redirect to options-reading.php

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

r21838 removed options-privacy.php and moved its one remaining option into options-reading.php. We should do a redirect from the former to the latter.

Attachments (1)

22349.patch (356 bytes) - added by johnbillion 8 years ago.

Download all attachments as: .zip

Change History (6)

@johnbillion
8 years ago

#1 @johnbillion
8 years ago

  • Keywords has-patch added

#2 follow-up: @nacin
8 years ago

We've gotten away with removing admin pages before without redirects many times before, such as categories.php, page.php, page-new.php, edit-pages.php, link-category.php, optons-misc.php, and the entire set of mu-* or ms-* files that made up the old Super Admin menu in MU and 3.0, respectively. Is this coming out of a simple suggestion, or have we seen a number of users affected by this in the forums?

#3 @johnbillion
8 years ago

It's not too important. The admin page of a plugin of mine links to options-privacy.php and clicking on it currently gives you a WSOD.

#4 in reply to: ↑ 2 @johnbillion
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Replying to nacin:

We've gotten away with removing admin pages before without redirects many times before

#5 @nacin
8 years ago

In 23050:

Remove options-privacy.php, as intended by [21838]. see #16416. see #22349.

Note: See TracTickets for help on using tickets.