WordPress.org

Make WordPress Core

#22397 closed defect (bug) (duplicate)

Editor - editor.js - removes paragraph tags inside tables

Reported by: warmstal Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Editor Keywords:
Focuses: Cc:

Description

Inside tables (td) editor is removing <p> tags.
Altough table editing is not standard activated in tinyMCE editor, but it can be added (plugin) or table editing can be done directly in HTML. So editor should respect <p> inside <td>

Path: editor.dev.js@line92

// Sepatate <div> containing <p>
//content = content.replace(/<div( [^>]*)?>\s*<p>/gi, '<div$1>\n\n');
//** WarmStal D!sign: www.warmstal.nl / BTS 01-03-2011 Not only for div but also for td
content = content.replace(/(<(td|div)[^>]*?>)\s*<p>/gi, '$1\n\n');

Change History (1)

comment:1 SergeyBiryukov18 months ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20943.

Note: See TracTickets for help on using tickets.