WordPress.org

Make WordPress Core

#22398 closed defect (bug) (duplicate)

Private Post Types Display "View Post" link in Messages

Reported by: mrwweb Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

One helpful attribute of post types with 'public' => 'false' is it hides the the "View Post" link in the admin bar, the permalink, etc.

However, the "View Post" link is still visible in the update messages. This should not be the case.

Change History (2)

comment:1 mrwweb17 months ago

In thinking through how this might get patched, I'm a little confused. Presumably a fix involves changing the $messages array, but translatable strings can't have variables in them. I think that may mean adding a new set of values to the array to handle private posts. What do others think?

comment:2 SergeyBiryukov17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17609.

Note: See TracTickets for help on using tickets.