WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#22411 closed defect (bug) (duplicate)

SubversionException: ("Can't open file '/home/svn/repos/wp-core/db/revs/12353': Too many open files", 24)

Reported by: ellipszist Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

How to Reproduce

While doing a GET operation on /changeset/22543/trunk, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'format': u'zip', 'new': u'22543', 'new_path': u'/trunk', 'old_path': u'/'}

User agent: Mozilla/5.0 (Windows NT 6.2) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/web_ui/changeset.py", line 349, in process_request
    self._render_zip(req, filename, repos, data)
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/web_ui/changeset.py", line 782, in _render_zip
    content = new_node.get_content().read()
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/svn_fs.py", line 720, in get_content
    self.pool()))
  File "/var/lib/python-support/python2.5/libsvn/fs.py", line 588, in svn_fs_file_contents
    return apply(_fs.svn_fs_file_contents, args)
SubversionException: ("Can't open file '/home/svn/repos/wp-core/db/revs/12353': Too many open files", 24)

Change History (2)

comment:1 @scribu3 years ago

  • Component changed from General to WordPress.org site
  • Milestone changed from Awaiting Review to WordPress.org

comment:2 @SergeyBiryukov3 years ago

  • Milestone WordPress.org deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22332.

Note: See TracTickets for help on using tickets.