WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 3 months ago

#22412 closed enhancement (duplicate)

Save posts via Ajax

Reported by: dgwyer Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Editor Keywords:
Focuses: Cc:

Description

When editing a post/page (as with any other type of document) one of the primary benefits is the undo/redo feature.

However, as soon as you update your changes you lose access to undo your previous keystrokes before the update. If you could save posts via Ajax then you would still be able to undo/redo post edits seamlessly.

Perhaps there could be a toggle in general settings for this option, and have it enabled by default?

Change History (5)

comment:1 @dgwyer2 years ago

Update: I realise that this happens via Ajax by default during auto-save but it would be very useful to have it do the same when you manually hit 'Update'.

comment:2 @alexvorn22 years ago

I think that sometimes auto-save function does not save custom meta settings, some are only saved by Update button.
http://codex.wordpress.org/Function_Reference/add_meta_box#Example

implementing Update - (ajax save) will eventually need for a code change and some 'old' post meta boxes will loose the functionality, I think so...

Last edited 2 years ago by alexvorn2 (previous) (diff)

comment:3 @toscho2 years ago

  • Cc info@… added

comment:5 @iseulde3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7756.

Note: See TracTickets for help on using tickets.