WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22418 closed defect (bug) (worksforme)

Enter Key Doesn't Work in Opera

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: major Version: 3.4.2
Component: TinyMCE Keywords: needs-testing
Focuses: Cc:

Description

Steps to reproduce (in Opera 12.10):

  1. Start a new post.
  2. Do some typing.
  3. Attempt to press the Enter key twice anywhere in the post.

Expected result:
Two blank lines with the cursor at the second line.

Actual result:
Cursor moves to the top of the post and inserts a blank line there. If I do this at the end of the post, I also get two blank lines at the end. If I do this in the middle of the post, it looks like about 3 blank lines get inserted there. Also note the "Path:" status changes to a blank value rather than "p".

Change History (10)

comment:1 dd3217 months ago

Using WordPress trunk, and Opera 12.10 (Build 1652), it works as expected for me, Which OS and can you check the build number? (on opera:about - I'd just like to check that the install I tested with wasn't RC4..)

I know Opera + mac + capturing keystrokes has been a real PITA in the past, as Opera didn't allow access to most keypresses, or it did, but mapped them to the completely wrong characters (eg, ( was mapped to the backspace for the last few releases in certain JS apps)

comment:2 miqrogroove17 months ago

Build 1652 on Win XP here. Not a trunk user.

comment:3 miqrogroove17 months ago

I should also specify the problem is in the Visual tab only. Enter works great in the HTML tab.

comment:4 helenyhou17 months ago

  • Component changed from Editor to TinyMCE

Does it happen in the TinyMCE demo? Their demo version may have changed in the meantime, though, and I think it has changed in trunk. It would be good to test on trunk instead, if it's a TinyMCE thing.

comment:5 SergeyBiryukov17 months ago

Could not reproduce in Opera 12.02 Build 1578 (Windows XP) neither in 3.4.2 nor in trunk.

Updated to Opera 12.10 Build 1652, still could not reproduce.

Last edited 17 months ago by SergeyBiryukov (previous) (diff)

comment:6 miqrogroove17 months ago

I'm able to reproduce this now on one site and not another in the same browser. I should be able to narrow this down some more.

comment:7 miqrogroove17 months ago

Actually, scratch that. The problem came back. It seems I can make the problem disappear temporarily by switching to the HTML tab and back to Visual.

In any case, if I do a select-all and delete, followed by some typing and then two Enter strokes, I get weird behavior.

Same results using Twenty Eleven theme and plugins disabled on 3.4.2.

Cannot reproduce the problem on the TinyMCE demo.

I guess I'm going to have to bite the bullet here and set up a trunk site.

comment:8 SergeyBiryukov17 months ago

  • Keywords needs-testing added

comment:9 miqrogroove17 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Works in trunk. Thanks for checking, everyone.

comment:10 SergeyBiryukov17 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to worksforme
Note: See TracTickets for help on using tickets.