WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22441 closed defect (bug) (fixed)

New Media: Upload button doesn't work in Internet Explorer 7-9

Reported by: jynxy Owned by: koopersmith
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: needs-patch
Focuses: Cc:

Description (last modified by ocean90)

Im unable to upload any images in the beta 3 using internet explorer 9, chrome works fine.

Change History (8)

comment:1 @ocean902 years ago

  • Cc koopersmith added
  • Component changed from General to Media
  • Description modified (diff)
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.5
  • Severity changed from major to normal
  • Summary changed from Unable to upload media/images in beta to New Media: Upload button doesn't work in Internet Explorer 7-9

That's right. Was just on the way to create a ticket. Koop will look into it.

comment:2 @SergeyBiryukov2 years ago

Confirmed. Clicking the "Select Files" button does nothing in IE 8/9.

comment:3 @SergeyBiryukov2 years ago

Also, "Drop files anywhere to upload" shouldn't be displayed in IE: #22446.

comment:4 follow-up: @lessbloat2 years ago

Looks like the "Media Library" link in media modal also appears to be broken now (tested in IE7 & IE8).

comment:5 in reply to: ↑ 4 @ocean902 years ago

Replying to lessbloat:

Looks like the "Media Library" link in media modal also appears to be broken now (tested in IE7 & IE8).

Works both for me. Are you using a real IE?

comment:6 @jynxy2 years ago

i have same issue as lessbloat. using windows 7, ie9 and all the lastest updates, patches etc that microsoft have so called fixed ;)

comment:7 @koopersmith2 years ago

  • Owner set to koopersmith
  • Resolution set to fixed
  • Status changed from new to closed

In 22611:

Media: The zIndex arms race.

Adjusts zIndexes to be not-as-absurd as before, in the process moving the modal below the plupload flash shims (which do not have customizable zIndexes or classes, sadly).

fixes #22441, see #22446, #21390.

comment:8 @koopersmith2 years ago

In 22612:

Media: zIndex peace was only temporary.

Revert [22611] in favor of using plupload's container setting. Turns out, plupload's flash shim is forced to the exact same index as the admin bar, so balancing the two is better solved by nesting the shim.

see #22441, #22446, #21390.

Note: See TracTickets for help on using tickets.