WordPress.org

Make WordPress Core

#22464 closed defect (bug) (invalid)

Featured Image

Reported by: jetonr Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

When I try to set a featured image the first time it fails to show. I have to go back pick the image from the uploads and hit update featured image to show! Testing on WP 3.5 beta 3! Another issue the color picker is not working on my theme anymore!

Change History (7)

comment:1 SergeyBiryukov17 months ago

  • Version set to trunk

comment:2 in reply to: ↑ description nacin17 months ago

  • Keywords reporter-feedback added

Replying to jetonr:

When I try to set a featured image the first time it fails to show. I have to go back pick the image from the uploads and hit update featured image to show! Testing on WP 3.5 beta 3!

This is mostly clear, but can you elaborate further?

Another issue the color picker is not working on my theme anymore!

Can you elaborate further? Is this a public theme? What color picker is being used? What code can we use to reproduce this?

comment:3 jetonr17 months ago

The thing with featured image is, after the image is uploaded I click on it I can see the tick added to the image but the button value/text at the bottom right corner is "select"! By clicking it the featured image will not be set, If I switch tabs to media library and than back again to uploaded files the button value/text at the bottom right corner is "update featured image" and this works!
So basically before users can set featured image they need to switch between tabs uploaded files and media library!
I hope that part is clear!

Now the color picker used in the NHP Framework is farbtastic and the code used to call the color picker for the filed is this:

jQuery(document).ready(function(){
	
	/*
	 *
	 * NHP_Options_color function
	 * Adds farbtastic to color elements
	 *
	 */
	//$colorpicker_inputs = jQuery('input.popup-colorpicker');
	$colorpicker_inputs = jQuery('input.popup-colorpicker').wpColorPicker();
	$colorpicker_inputs.each(
	function(){
	var $input = jQuery(this);
	var sIdSelector = "#" + jQuery(this).attr('id') + "picker";
	var oFarb = jQuery.farbtastic(
	sIdSelector,
	function( color ){
	
	$input.css({
	backgroundColor: color,
	color: oFarb.hsl[2] > 0.5 ? '#000' : '#fff'
	}).val( color );
	
	
	if( oFarb.bound == true ){
	$input.change();
	}else{
	oFarb.bound = true;
	}
	}
	);
	oFarb.setColor( $input.val() );
	
	}
	);
	
	$colorpicker_inputs.each(function(e){
	jQuery(this).next('.farb-popup').hide();
	});
	
	
	$colorpicker_inputs.live('focus',function(e){
	jQuery(this).next('.farb-popup').show();
	jQuery(this).parents('li').css({
	position : 'relative',
	zIndex : '9999'
	})
	jQuery('#tabber').css({overflow:'visible'});
	});
	
	$colorpicker_inputs.live('blur',function(e){
	jQuery(this).next('.farb-popup').hide();
	jQuery(this).parents('li').css({
	zIndex : '0'
	})
	});
});

comment:4 SergeyBiryukov17 months ago

  • Component changed from General to Media

comment:5 koopersmith17 months ago

I can't reproduce this bug.

jetonr, are you testing on trunk or beta 3?

comment:6 jetonr17 months ago

beta 3 koopersmith https://dl.dropbox.com/u/3271214/color_picker.jpg

comment:7 nacin17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

koopersmith was asking about your featured image issue. These are two separate bugs that is confusing everyone, so I am going to close this ticket as invalid. You are welcome to open individual, descriptive tickets for your issues. Please include clear steps to reproduce.

Note: See TracTickets for help on using tickets.