WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#22489 closed defect (bug) (duplicate)

If no pages, except for the Sample page, exist, automatically creating a new page fails when enabling a static front page.

Reported by: ldebrouwer Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: General Keywords: has-patch needs-testing
Focuses: Cc:
PR Number:

Description

If no pages, except for the Sample page, exist, automatically creating a new page fails when enabling a static front page. This is due to $_POST[ 'page_on_front' ] not existing and not having the value "new".

How to reproduce:

  • Install a fresh checkout of trunk.
  • Go to Setting > Reading
  • Check "Show a page instead of your latest posts"
  • Hit "Save changes"

Attachments (1)

page_on_front.diff (740 bytes) - added by ldebrouwer 7 years ago.
This fixes the problem. It creates a hidden input "page_on_front" with value "new".

Download all attachments as: .zip

Change History (3)

@ldebrouwer
7 years ago

This fixes the problem. It creates a hidden input "page_on_front" with value "new".

#1 @SergeyBiryukov
7 years ago

Also reported in ticket:16379:84 and can be fixed with ticket:16379:16379.9.patch.

However, the UI may be changed again soon, so the fix wasn't committed yet.

#2 @nacin
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #16379.

Note: See TracTickets for help on using tickets.