WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22490 closed defect (bug) (fixed)

New buttons: Disabled state in iOS

Reported by: johnbillion Owned by: koopersmith
Milestone: 3.5 Priority: normal
Severity: minor Version: 3.5
Component: UI Keywords: has-patch needs-testing
Focuses: Cc:

Description

Disabled buttons retain their pill-like rounded corners in iOS.

Attachments (3)

ios-disabled-buttons.png (5.3 KB) - added by johnbillion 17 months ago.
22490.diff (403 bytes) - added by johnbillion 17 months ago.
Patch
ios-buttons-after.png (5.0 KB) - added by johnbillion 17 months ago.
After

Download all attachments as: .zip

Change History (10)

johnbillion17 months ago

Patch

johnbillion17 months ago

After

comment:1 johnbillion17 months ago

  • Keywords has-patch added

Patch.

Note that if you're using Chrome on iOS (and maybe Safari too), its caching is very aggressive. Clearing the cache from the Settings menu doesn't clear all files in the cache, such as some CSS files. It's very odd. I ended up bumping the version number in wp-includes/version.php to get the updated buttons.css to load.

comment:2 follow-up: azaozz17 months ago

  • Keywords needs-testing added

Don't see the pill shapes in Safari/iOS6. Removing the internal -webkit-appearance: push-button; might have other implications.

comment:3 in reply to: ↑ 2 johnbillion17 months ago

Replying to azaozz:

Don't see the pill shapes in Safari/iOS6.

Looks like it's an iOS 5 issue then. Confirmed in Chrome and Safari on iOS 5.

Removing the internal -webkit-appearance: push-button; might have other implications.

Are there implications other than appearance? We have rules in place for border, background, font, padding, etc etc.

comment:4 SergeyBiryukov17 months ago

  • Type changed from enhancement to defect (bug)

comment:5 nacin17 months ago

Best I can tell, it does not appear to have any implications beyond appearance.

comment:6 koopersmith17 months ago

  • Owner set to koopersmith
  • Resolution set to fixed
  • Status changed from new to closed

In 22704:

Buttons: Ensure correct disabled submit button state in iOS. props johnbillion, fixes #22490.

comment:7 ocean9017 months ago

  • Milestone changed from Awaiting Review to 3.5
Note: See TracTickets for help on using tickets.