WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#22505 closed defect (bug) (worksforme)

Toolbar dropdowns don't hide on front end on tap away

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Toolbar Keywords:
Focuses: Cc:

Description

In the wp-admin pages I can open the Howdy or New menus and tap away to close them.

In the front end admin bar, the menu stays open until navigating to a new page.

Found on 3.5-beta3-22637 using iPad3 iOS 6.0.1.

Change History (13)

#1 @georgestephanis
7 years ago

Does your front end have jQuery loaded? I'm not sure if we included a fallback for non-jQuery (which we should probably address)

#2 @miqrogroove
7 years ago

It does not. I double checked this happens in Twenty Twelve. IMO, the front-end admin bar shouldn't use jQuery at all unless it is included.

#3 @SergeyBiryukov
7 years ago

  • Component changed from General to Toolbar

#4 @helenyhou
7 years ago

  • Summary changed from Admin Bar Doesn't Hide on Front End to Toolbar dropdowns don't hide on front end on tap away

I recall it being like this on both the front and in the admin previously (3.4.2 and before), at least on iOS 5.

#5 @georgestephanis
7 years ago

I'm conceptually fine with doing it in jQuery with a slightly-less-functional fallback if jQuery isn't loaded. But we need to let people close the menus as a minimum.

We don't currently enqueue jQuery on the front end, nor do I think that we should just because of the toolbar.

#6 @miqrogroove
7 years ago

Yeah I'm in favor of the fallback.

#7 @miqrogroove
7 years ago

  • Version changed from trunk to 3.4.2

Not a "regression" for 3.5.

#8 @devinreams
7 years ago

  • Cc devin@… added

#10 @miqrogroove
6 years ago

Same problem in 3.7.1. The 2013 theme actually works, but 2012 and similar do not.

#11 @morganestes
4 years ago

  • Keywords needs-patch added

#12 @morganestes
4 years ago

  • Keywords needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

Tested in 4.3 trunk on Android Chrome with Twenty Twelve and Twenty Fifteen themes and can't reproduce. I've also been told that iOS works as well.

I'm going to close this, but if it becomes another problem we can reopen or create a new ticket.

#13 @netweb
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.