WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#22529 closed defect (bug) (duplicate)

"All Images" not appearing in Media Library

Reported by: blepoxp Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: needs-patch
Focuses: Cc:

Description

Hi,
I'm finding that in specific instances, the "All Media" selection does not populate with all the media. I'm sure I'm not using the correct terminology so here's how to reproduce:

  1. Make sure your test install already has items in the Media Library
  2. Go to a post/page where you can set featured Image and click 'Choose a Featured Image'.
  3. When the dialog pops up, immediately click 'Media Library' in the left column and find that all site media appears for you to select. (I assume this is working as intended).
  4. Close dialog and refresh the edit post/page screen to reset everything
  5. Click the 'Choose a Featured Image' button
  6. When the dialog opens, immediately click "Select File" and upload a file.
  7. After the file uploads, click the 'Media Library' link in the left column and find that All Media is not shown even thought he dropdown indicates it should be. (This seem it is not working as intended.)

Another interesting twist that may help in debugging. If you restart at step 4 above but do the following between steps 5 and 6, you'll find that step 7 works like it does in step 3:

5.5: Before clicking "Select File" in step 6, click "Media Library" in left column. Then click "Upload Image" again. Then Upload your image.

Change History (1)

#1 @koopersmith
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22480.

Note: See TracTickets for help on using tickets.