WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22536 closed defect (bug) (fixed)

view-switcher icon do not show on Chrome

Reported by: macbrink Owned by: azaozz
Milestone: 3.5 Priority: normal
Severity: minor Version: 3.5
Component: Administration Keywords:
Focuses: Cc:

Description

The view-switcher icons do not show on Google Chrome
On IE(10) and FF (8.0.1) they can be seen.
working with Chrome 25.0.1323.1 on Windows 8


Attachments (1)

list-view.jpg (8.5 KB) - added by macbrink 17 months ago.

Download all attachments as: .zip

Change History (8)

macbrink17 months ago

comment:1 duck_17 months ago

  • Milestone changed from Awaiting Review to 3.5

Tracked this down to [22425] for wp-includes/images/blank.gif.

comment:2 azaozz17 months ago

Yeah, seems the optimization turned blank.gif from transparent to white matte. Checking the other optimized GIFs, all have changes to the transparency/matte and there's no size reduction or it's negligable. Best not to smush/ImageOptim GIFs.

comment:3 azaozz17 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 22829:

Do not optimize/smush/ImageOptim GIFs. Most are either not reduced in size or reduced only couple of bytes but the optimization messes with the transparency/matte. Fixes #22536, see #22381

comment:4 follow-up: macbrink17 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

The GIFs were transparent already. it worked in IE and FF, Chrome is still not showing the icons, see my specs above.

comment:5 in reply to: ↑ 4 SergeyBiryukov17 months ago

Replying to macbrink:

Chrome is still not showing the icons

I can reproduce in 3.5-RC1, but I see the icons in trunk after [22829] in Chrome 23.

Last edited 17 months ago by SergeyBiryukov (previous) (diff)

comment:6 macbrink17 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I'm running Chrome 25.0.1323.1, maybe I should report this bug to Chrome.

comment:7 azaozz17 months ago

The problem is that GIF quality/transparency is changed while optimizing and there is little or no file size reduction. Perhaps there is another app that would keep the images unchanged, or maybe GIFs can't be optimized :)

Last edited 17 months ago by azaozz (previous) (diff)
Note: See TracTickets for help on using tickets.