WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22539 closed enhancement (duplicate)

filters to get Image Editor class are not sufficient

Reported by: macbrink Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

If a plugin implements another Image Editor class, the information in the filters is not enough to choose the class.
A plugin that overrides the generate_filename() method for images that are not in the wp_upload directories, need access to the original path.
Neither 'wp_image_editors' or 'wp_image_editor_class' filter pass this information.

Attachments (1)

wp_get_image_editor_patch.diff (617 bytes) - added by macbrink 2 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 @macbrink2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22538.

comment:2 @SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.