WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 3 months ago

#22548 closed enhancement (duplicate)

Better behaviour when embedding oEmbed supported URLs

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

If a user isn't aware that they can just paste the URL of a video from YouTube/Vimeo/etc into a post in order to embed it, then the user experience for embedding such content could do with some improvement.

In this recent user interaction test by lessbloat, the user was given a URL to a Vimeo video and asked to embed it into their post. The user clicked 'Add Media', switched to the 'Embed From URL' tab and pasted the URL there. All that happened was the URL to the video was inserted into the post as a formatted link (<a href="{url}">{title}</a>). This meant oEmbed didn't do its thing when the post was displayed and the user just ended up with a link to the Vimeo URL.

What Should Happen

URLs inserted via the 'Embed From URL' tab in the media modal should be handled according to whether or not there's oEmbed support for the URL. To do this an AJAX request should be fired off to a new AJAX handler which reports whether there's oEmbed support for the URL. If there is, then a UI element (message/icon/something) should be shown indicating that the media will be embedded. As a bonus we could even grab the oEmbed data immediately and display the title/thumbnail/etc if it's relevant.

Note that if you paste a URL to an image file (gif/png/jpeg) you're immediately shown an interface for entering a caption and selecting the alignment and the link. This is nice behaviour and improves on the UI we had in 3.4.


This isn't specific to the new media modal because this has always been the behaviour, but marking as an improvement to trunk anyway (I'd call this a bug, but I'll leave it as an enhancement).

Change History (2)

comment:1 johnbillion3 months ago

#11319 was marked as a duplicate.

comment:2 helen3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15490.

Note: See TracTickets for help on using tickets.