WordPress.org

Make WordPress Core

#22550 closed defect (bug) (invalid)

Unable to Post in Debug Mode Unless Super Cache is Deleted

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: major Version: 3.4.2
Component: Cache API Keywords:
Focuses: Cc:

Description

There might be a legitimate bug in the core cache architecture. Some flaw in the Super Cache phase 2 file is causing a WSOD even when the plugin is deactivated.

Is there a way to enforce the removal of the cache hooks with deactivation? Or is this strictly a non core issue?

Change History (6)

comment:1 miqrogroove17 months ago

Steps to reproduce:

  1. Enable debug mode and display_errors.
  2. Install WP Super Cache and enable php mode caching.
  3. Deactivate WP Super Cache.
  4. Attempt to publish a post.

comment:2 scribu17 months ago

  • Keywords reporter-feedback added; dev-feedback removed

It's a regression only if it works fine in WP 3.4.2.

comment:3 miqrogroove17 months ago

  • Keywords reporter-feedback removed

That's correct.

comment:4 miqrogroove17 months ago

  • Version changed from trunk to 3.4.2

Same WSOD on 3.4.2.

comment:5 miqrogroove17 months ago

  • Summary changed from Unable to Post in RC1 Unless Super Cache is Deleted to Unable to Post in Debug Mode Unless Super Cache is Deleted

comment:6 scribu17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Is there a way to enforce the removal of the cache hooks with deactivation?

Yes, we have register_deactivation_hook(), which SuperCache could use to remove it's special files from wp-content.

Feel free to re-open if it turns out it's a Core bug.

Note: See TracTickets for help on using tickets.