WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22584 closed defect (bug) (worksforme)

Typo: Missing blank

Reported by: pixolin Owned by:
Milestone: Priority: normal
Severity: trivial Version:
Component: Administration Keywords:
Focuses: Cc:

Description

After running an update I receive the message "… updated successfully. Show DetailsHide Details." with a missing blank in "DetailsHide".

http://core.trac.wordpress.org/browser/trunk/wp-admin/includes/class-wp-upgrader.php#L1236

is

$this->upgrader->strings['skin_update_successful'] = __('%1$s updated successfully.').' <a onclick="%2$s" href="#" class="hide-if-no-js"><span>'.__('Show Details').'</span><span class="hidden">'.__('Hide Details').'</span>.</a>';

but should be

$this->upgrader->strings['skin_update_successful'] = __('%1$s updated successfully.').' <a onclick="%2$s" href="#" class="hide-if-no-js"><span>'.__('Show Details').'</span> <span class="hidden">'.__('Hide Details').'</span>.</a>';

Attachments (4)

screenshot.jpg (60.6 KB) - added by pixolin 17 months ago.
Screenshot of the message with the missing link.
pixolin-22584.diff (1.2 KB) - added by miqrogroove 17 months ago.
Solution from description.
miqro-screen-shot.png (30.5 KB) - added by miqrogroove 17 months ago.
My attempt to reproduce this on 3.5-RC1.
miqro-show-details.png (33.1 KB) - added by miqrogroove 17 months ago.
After clicking the "Show Details" link.

Download all attachments as: .zip

Change History (15)

pixolin17 months ago

Screenshot of the message with the missing link.

comment:1 follow-up: ocean9017 months ago

  • Keywords close added

They shouldn't be displayed together. Seems like the CSS file wasn't loaded here.

Last edited 17 months ago by ocean90 (previous) (diff)

comment:2 in reply to: ↑ 1 miqrogroove17 months ago

Replying to ocean90:

They shouldn't be displayed together. Seems like the CSS file wasn't loaded here.

Also that line hasn't changed in the trunk version since 3.4.2. What are the steps to reproduce this issue?

comment:3 follow-up: markoheijnen17 months ago

I'm curious which CSS wasn't loaded then. Can't see anything for that. Also weird to do that spacing with CSS instead of a space

miqrogroove17 months ago

Solution from description.

comment:4 in reply to: ↑ 3 ocean9017 months ago

Replying to markoheijnen:

I'm curious which CSS wasn't loaded then.

Must be wp-admin.css, since the color exists, which is defined in color-*.css. Have in mind, that it's an iframe request.

How it does look for me: http://cl.ly/L7OX and http://cl.ly/L74e

comment:5 miqrogroove17 months ago

I've attempted to reproduce this on 3.4.2 and on 3.5-RC1. In both, I never get output beyond "Downloading update from http://wordpress.org/extend/themes/download/twentyeleven.1.4.zip…" Is this another bug?

comment:6 miqrogroove17 months ago

Never mind previous comment. I just noticed from the original screen shot that this is happening on the Updates page, not on the Themes page, which seems to have totally different output.

miqrogroove17 months ago

My attempt to reproduce this on 3.5-RC1.

comment:7 miqrogroove17 months ago

In miqro-screen-shot.png you can see that the second link is not supposed to be displayed as it was in screenshot.jpg.

miqrogroove17 months ago

After clicking the "Show Details" link.

comment:8 miqrogroove17 months ago

See also miqro-show-details.png​. Unable to reproduce this bug in RC1 so far.

comment:9 pixolin17 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

I am sorry! It turns out I had an older beta version installed. Should pay more attention next time.

comment:10 helenyhou17 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Version trunk deleted

comment:11 SergeyBiryukov17 months ago

  • Component changed from General to Administration
Note: See TracTickets for help on using tickets.