WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 months ago

#22633 closed enhancement (maybelater)

Admin Bar Update Icon Inconsistency

Reported by: TJNowell Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: ux-feedback ui-feedback needs-patch
Focuses: ui, administration Cc:

Description

The update icon at the moment is 2 arrows in a circle in the admin bar ( aka the refresh icon ). In Network Admin it's a pair of tools.

I'd suggest we change these to the same icon rather than have 2 inconsistent icons. I'd also suggest we use a single arrow as the new icon, a refresh/recycle icon isn't as clearcut as it could be ( and what if a caching plugin implements a refresh button to the admin bar? ).

We could follow Google by using an arrow pointing upwards, or we could follow Apples convention with a downwards pointing arrow in a circle

Attachments (4)

Screen Shot 2012-11-29 at 11.36.15.png (8.1 KB) - added by TJNowell 5 years ago.
Chrome update icon
IMG_3262.PNG (117.4 KB) - added by TJNowell 5 years ago.
iOS Update
Screen Shot 2016-06-26 at 11.58.59.png (22.3 KB) - added by wgroenewold 17 months ago.
Download icon (arrow in box)
temp.png (563.1 KB) - added by wgroenewold 17 months ago.
Update icon states

Download all attachments as: .zip

Change History (19)

@TJNowell
5 years ago

Chrome update icon

@TJNowell
5 years ago

iOS Update

#1 @helenyhou
5 years ago

  • Component changed from UI to Administration
  • Keywords ux-feedback ui-feedback added

#2 @jeremyfelt
4 years ago

  • Focuses ui added
  • Summary changed from Update Icon Inconsistency to Admin Bar Update Icon Inconsistency

#3 @nacin
4 years ago

  • Component changed from Administration to Upgrade/Install
  • Focuses administration added

#4 @Ipstenu
4 years ago

As of 3.9, I see the circle refresh for Network Admin

https://i.cloudup.com/Aeqq5aRlYN-3000x3000.png

So it looks like that half of the problem is now resolved. The question of should we use a better icon that refresh is interesting, though. A 'refresh' isn't really indicative of 'I'm gonna update your plugins and themes now!'

This ticket was mentioned in IRC in #wordpress-dev by ipstenu. View the logs.


4 years ago

#6 @chriscct7
2 years ago

  • Keywords needs-patch added

This ticket was mentioned in Slack in #design-dashicons by ocean90. View the logs.


18 months ago

@wgroenewold
17 months ago

Download icon (arrow in box)

#8 @wgroenewold
17 months ago

Is there a reason why we don't use the icon for download (arrow down in box) or a variation on that when there are updates available and another icon (like a checkmark or a when all the updates are done? That way there would be an extra incentive to do updates.

We could do something like arrow down in a shape if updates are available, animating dot when checking in a shape and checkmark when everything is up to date.

This ticket was mentioned in Slack in #design by wgroenewold2. View the logs.


17 months ago

@wgroenewold
17 months ago

Update icon states

#10 @wgroenewold
17 months ago

Retought it a little. Added a small mockup of the idea. Not sure about the animated icon though.

Last edited 17 months ago by wgroenewold (previous) (diff)

This ticket was mentioned in Slack in #design by karmatosed. View the logs.


3 months ago

#12 @melchoyce
3 months ago

Is this still an issue on multisite? I agree the icons should be inconsistent, but I don’t think we need an updated icon — especially if we haven’t gotten more comments on this thread from folks who do find it confusing, or from forum threads. However, if anyone wanted to run some usability tests at some meetups or WordCamps, that could help bring in some data. :)

#13 @joyously
3 months ago

This is why I don't like icons! They all can be misinterpreted so easily.
A down arrow to me means download. An up arrow would be upload. Arrows in a circle to me mean recycle.

#14 @Ipstenu
3 months ago

We're currently internally consistent, so I think that's okay unless we want to revisit as "Do we need new icons?"

#15 @melchoyce
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

In that case, I'm going to close as maybelater, and if someone wants to take on testing out new icons, feel free to reopen.

Note: See TracTickets for help on using tickets.