Make WordPress Core

Opened 3 years ago

Closed 3 months ago

#22635 closed defect (bug) (worksforme)

comments made on iPad get the comment_author_url removed in the pre_comment_author_url filter

Reported by: commentluv Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Comments Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

I have tested this on version (3.5-RC1-22909) nightly build too.

if I submit a comment with a valid author url using the iPad then the URL gets removed by the pre_comment_author_url filter in wp-includes/comment.php


  • windows 7 works fine
  • windows xp works fine
  • debian box works fine
  • macbook pro works fine

Not working

  • iphone ios 5.1.1
  • ipad ios 5.1.1

duplicable on local, live and someone elses site.

I can see the POST vars show all the proper data.

in wp-includes/comment.php the wp_filter_comment function the $commentdata['comment_author_url'] exists before

$commentdata['comment_author_url']   = apply_filters('pre_comment_author_url', $commentdata['comment_author_url']);

(line 1291 of wp-includes/comment.php (3.4.2)

but is gone after the filter has been applied,

this happens only if using an ipad or iphone.

Change History (6)

#1 follow-up: @MikeHansenMe
3 years ago

  • Cc mdhansen@… added

I was able to reproduce this on iPhone 5.1.1 however I tried with iPad 6.0.1 and it worked as expected.

#2 in reply to: ↑ 1 @commentluv
3 years ago

Replying to MikeHansenMe:

I was able to reproduce this on iPhone 5.1.1 however I tried with iPad 6.0.1 and it worked as expected.

I can't confirm 6.0.1 because I need my iDevices jailbroken so I can edit their hosts file to allow me to browse local network sites for development.

thanks for confirming it is happening with 5.1.1 though

now all we need is a fix :)

#3 @SergeyBiryukov
3 years ago

  • Component changed from General to Comments
  • Description modified (diff)

#4 @obenland
23 months ago

  • Keywords reporter-feedback added
  • Severity changed from major to normal

I could not reproduce it on either iPad3 or iPhone5 with iOS 7.0.4

#5 @SergeyBiryukov
23 months ago

but is gone after the filter has been applied

Sounds like a plugin is filtering it out. The only functions attached to this filter in core are wp_strip_all_tags(), esc_url_raw(), and wp_filter_kses(): tags/3.8/src/wp-includes/default-filters.php#L59.

#6 @rachelbaker
3 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed


I was also not able to reproduce the issue. Closing this issue for now, re-open if I am missing something.

Note: See TracTickets for help on using tickets.