WordPress.org

Make WordPress Core

#22636 closed defect (bug) (duplicate)

Add a filter for post_thumbnail_meta_box HTML

Reported by: coreygilmore Owned by: nacin
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Post Thumbnails Keywords: needs-patch
Focuses: Cc:

Description

It's been helpful to add additional HTML to the post thumbnail meta box, but without any hooks in post_thumbnail_meta_box the process is very fragile, and and requires the use of Javascript, or removing the postimagediv meta box and adding your own meta box.

_wp_post_thumbnail_html provides a way to filter the HTML, but function is only used for ajax requests.

The attached patch adds a filter to $thumbnail_html in post_thumbnail_meta_box, allowing for some parity.

Attachments (1)

meta-boxes.php.diff (610 bytes) - added by coreygilmore 17 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 helenyhou17 months ago

I don't think _wp_post_thumbnail_html() fires at all anymore. Seems like we need backcompat for the admin_post_thumbnail_html filter, at least. Maybe for all of the output, even the JS, since it has title and update text in _e() and the filter is often used to change some of the text rather than using gettext().

comment:2 nacin17 months ago

  • Milestone changed from Awaiting Review to 3.5
  • Type changed from enhancement to defect (bug)

comment:3 devinreams17 months ago

  • Cc devin@… added

comment:4 batmoo17 months ago

  • Cc batmoo@… added

comment:5 koopersmith17 months ago

  • Keywords needs-patch added; has-patch removed

comment:6 micahwave17 months ago

  • Cc micahwave added

comment:7 nacin17 months ago

  • Owner set to nacin
  • Status changed from new to assigned

comment:8 koopersmith17 months ago

Note that this will be fixed by the patch on #21776.

comment:9 nacin17 months ago

  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #21776.

Note: See TracTickets for help on using tickets.